Talk

Advanced search

Anyone having problems with Firefox this morning or is it just me?

(9 Posts)
Buda Tue 04-Aug-09 08:52:17

It was working fine and then I logged off. Now get an error message when I try to log on. Explorer working ok so obv not my internet connection. And now I am realising why I dislike Explorer! I want my Firefox back!

stripes200 Tue 04-Aug-09 08:55:15

I'm currently firing my fox just fine smile

Might just be you. Try restarting.

serenity Tue 04-Aug-09 08:57:26

Mine's fine too (sorry!)

purepurple Tue 04-Aug-09 09:01:12

no problems with mine either

Poledra Tue 04-Aug-09 09:02:12

My Firefox does this occasionally - I have to shut down the PC and restart to get it to work again.

Buda Tue 04-Aug-09 09:19:14

Thanks all. Will try shutting down. We had a power cut last night and then a storm in the night so I suppose something might have happened. Although it did all fire up ok first thing.

Buda Tue 04-Aug-09 09:45:21

Well tried shutting down and re-starting but no joy. Oh well. Will stick to Explorer for the moment.

PersonalClownisaShoeWhore Wed 05-Aug-09 10:20:41

I've got this today.
It uploaded an update for me and now tell me that there is a problem loading the page.
I want my Firefox back too!!

Buda Wed 05-Aug-09 11:50:16

We ended up reloading it and now have no problems (fingers crossed!).

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now