Talk

Advanced search

Got questions about giving birth? Know what to expect and when to expect it, with the Mumsnet Pregnancy Calendar.

Elective section - post section lochia and show? Warning TMI

(5 Posts)
hockeymum Sun 28-May-06 20:52:12

I had an elective section 5 weeks ago so I obviously didnt go into labour. I had the usual lochia and yuckiness for 3-4 weeks which has now stopped, but for the last few days I've noticed the occassional mucous loss that seems to be a bit like the show I had when I went into labour with my first child. Could this be the show that didnt come out because I didnt go into labour? wouldn't it have come out before now? Or is it something more suspicious? It's not smelly or anything so I'm pretty certain it's not an infection. Anyone else have this?

zephyrcat Sun 28-May-06 21:13:56

Hiya - I had this quite a bit after my lastest CS. It was almost 8 weeks ago now so it has pretty much stopped but after the lochia stopped there was definately something resembling a 'show'- sometimes pinky, sometimes just clear - weird stuff really (trying not to go into TMI!!)

zephyrcat Sun 28-May-06 21:15:10

Lastest??! Latest!!

hockeymum Mon 29-May-06 10:06:49

Thanks Zephyrcat - sounds exactly the same, glad it's normal!

hockeymum Mon 29-May-06 10:07:06

Thanks Zephyrcat - sounds exactly the same, glad it's normal!

Join the discussion

Registering is free, easy, and means you can join in the discussion, watch threads, get discounts, win prizes and lots more.

Register now »

Already registered? Log in with: