Am i pregnant???

(7 Posts)
user1469720282 Sat 20-Aug-16 19:11:18

Hi im new here,

Basically im on the implant have had it since December 2013, periods have been more or less normal so no issues with the Implant. For the past 2 weeks i started off with brown discharge, have had pinkish blood, bright red blood and sometimes the blood is only there when i wipe. I dont know when my last period was as they do be all over the place, i have been feeling veryyyyy sleepy recently, quite sick etc. I did a test on the 2nd of this month and then bang on 2 weeks another test which was the 16th but both came out negative.

Could i still be pregnant though or could it be something else?

Thank u in advance

physicskate Sat 20-Aug-16 19:53:32

Pregnancy seems a bit unlikely if you've had negative tests and have been feeling the 'symptoms' for that long. Maybe test again in another day or two - remember there only has to be a sniff of a line for it to be positive.

This seems like it is worth a trip to the GP to ask about... bleeding for two weeks is worth a chat!

user1469720282 Sat 20-Aug-16 20:07:29

Thank u so much for the reply!!

The bleeding has been very little though so didnt think there was any need to see a GP to be honest.

But obviously doing 2 tests which have come up negative seem abit wierd.

Must have a trip to the GP then, they dont really give u appointments for the same day so most likely will have to wait a week or so to get an appointment!

user1469720282 Sat 20-Aug-16 20:10:45

Also dont know wether its worth mentioning or not but i am a Mum of a nearly 3 year old born in August 2013 and i got the implant inserted in December 2013

Difficultyear2015 Sat 20-Aug-16 22:17:46

Watching with interest as I have had brown / pink discharge on and off for 8 days now since what looks to be 11 or 12 DPO.

At first thought it was implantation as it stopped after 4 days and no sign of AF followed, but it started again today and my heart sank thinking something was wrong.

I was going to test tomorrow but don't want to now as I am worried something is wrong and people say it's unlikely to be implantation but more likely a hormonal imbalance anyway.
I have had all my hormone tests done at the hospital back at end of July (they keep a close eye on me since last year) and my results all came back within the normal levels.

I can't easily get to my doctor so not too sure if I wait it out another week first and see what happens.

I have had no cramping or pain so assume that's a good sign.

Lots of bloating, lots of gas, greasy skin, dry scalp, lots of very wet CM and lightheaded mixed with queasy spells on and off and severe headaches.

I had very light spotting for 5 days when I became pregnant last year (unfortunately didn't make it to full term) and all the same signs are there but I am still spotting.

When I say spotting I am talking about a light pink or brown tinge to discharge when I wipe. Nothing shows in Underwear.

I thought it might be coinciding with having sex as we typically DTD most days or every other day at the least.
Not too sure now as its only happened for me this month and for the last 8 days on and off, so unless I have all of a sudden developed a cyst or cervical erosion I'm baffled

user1469720282 Sat 20-Aug-16 22:41:51

Well i thought the bleeding for me had stopped on the 15th so decided to take a pregnancy test on the 16th which came back negative, but after a couple of hours the bleeding started again but it has been very very light since then

physicskate Sat 20-Aug-16 23:03:29

The real difference here is being on the implant vs not... It may be that the implant is coming to the end of its natural life and needs replacing, or it could be anything. Best to ask go.

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now