Talk

Advanced search

Would you like to be a member of our research panel? Join here - there's (nearly) always a great incentive offered for your views.

Lab found blood in urine but no sign of infection, should I be worried?

(6 Posts)
Issy42 Sat 15-Aug-09 12:37:29

I got a call from my doctors yesterday to say that they found blood in the urine sample I gave last week (at 17 weeks) but there is no sign of an infection. I have to give a new sample on Monday to double check. In the meantime I've googled and read that this could indicate a problem with the pregnancy, so now I'm worried.

Has anyone experienced this? Or know about it?

maybebaby23 Sat 15-Aug-09 12:58:31

I had this in my last pregnancy. The doctor called me in and i was worried to death too! Then she told me its probably just a pregnancy thing and as long as there was no infection it will be fine. She just said it happens sometimes in pregnancy.

Issy42 Sat 15-Aug-09 13:06:51

Thanks for the reassurance maybebaby. Should know better than google, just when they start the conversation with 'we don't want you to worry but ...' or words to that effect, it always makes me worry blush.

mogend77 Sat 15-Aug-09 13:09:08

"just when they start the conversation with 'we don't want you to worry but ...' or words to that effect, it always makes me worry."

Oh yes - that's as good as saying "don't look now but ....."

maybebaby23 Sat 15-Aug-09 15:17:59

lol Thats true, my doctor knows i panic about things (slight health anxiety going on here blush ) so she always starts off with "dont panic but..." Im sure she does it on purpose!

Issy42 Mon 17-Aug-09 14:03:27

Well I've given in the new sample, so hopefully that will be OK. No idea when they'll get the results though - I guess Friday since I gave in the previous sample last Monday.

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now