Talk

Advanced search

Would you like to be a member of our research panel? Join here - there's (nearly) always a great incentive offered for your views.

Symptoms following sweep... am I getting somewhere?!

(6 Posts)
Libbywx Mon 19-Dec-16 05:46:23

Im 40 weeks + 2. Following my sweep at 9 on Saturday morning (the following may be TMI!) I've had lots of dark brown discharge, after that lots of pink watery mucous and now a huge glob of yellow snotty stuff (I'm assuming that was the mucous plug?)

I'm getting crampy period type pains and dull back ache but it's very infrequent. Sometimes nothing for 6 hours.... am I getting somewhere or are these just typical after sweep symptoms?

Any help appreciated. I'm desperate to get my little man here now! X

Whatsername17 Mon 19-Dec-16 08:29:26

That's what happened to me after a sweep and I delivered 36 hours later! Good luck!

Libbywx Mon 19-Dec-16 09:12:28

Thanks for responding. I really hope so! I'm getting to the end of my rope now. Hip pain is the worst!!!!!

RatOnnaStick Mon 19-Dec-16 09:14:55

Sounds like very early labour to me. Could carry on for a few days or could ramp up and you have a baby by this time tomorrow. Either way, your body is getting ready.

AddictedtoGreys Mon 19-Dec-16 09:34:44

I had those period type pains through the night after my sweep, but some were hours apart like yours. My contractions started coming regularly at 12pm the next day so about 22 hours after the sweep. My DD was born at 11.20pm that night smile

chloechloe Mon 19-Dec-16 11:02:53

I didn't have a sweep but I went into labour a week after losing my mucous plug. Impossible to say how long it will be but things are moving in the right direction!

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now