Advertisement

loader

Talk

Advanced search

Blocked gas burners

(5 Posts)
WittgensteinsBunny Mon 01-Dec-14 21:01:29

All of the rings on our range seem to be only partially working. We have to light them with matches as the ignition is clicking but not lighting the gas. Does anyone know how to clean them? We do clean the top every day but I reckon it's a build up of spills and things boiling over causing the problem. mil seems to think that a soak in hot soapy water and a scrub with wire wool should do the trick. Any other tips? Thanks!

wowfudge Mon 01-Dec-14 23:21:47

I think it's nothing to do with the burners if you can light them using matches. Sounds to me as though the ignition battery needs changing. Dig out the manual and find out where it goes.

On my old gas cooker the battery was located under the front edge to one side - no idea whether that's a standard location.

PinkiPhone Mon 01-Dec-14 23:48:31

Try hoovering it! I'm not joking! We did it when we moved in and struggled to get the gas to ignite. Worked a charm. Best of luck!

wowfudge Tue 02-Dec-14 23:15:03

Have you been able to sort it OP?

WittgensteinsBunny Wed 03-Dec-14 09:22:38

So the good news is that all of the burners are now working properly. Some only had a couple of flames coming out of them, so we just didn't use them. A good soaking and poking each hole with a pin solved that. They are all working beautifully. Some still don't light with the ignition, so I'm going to call an engineer to come and service it. Thanks for all the tips smile

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now