Talk

Advanced search

Wireless network not working properly - only able to access some websites

(14 Posts)
MsHighwater Fri 23-Oct-09 22:15:53

Thank goodness MN is one of them. Have laptop and PC and both are affected the same so assume it must be the wireless modem. I can connect to some webpages but not others. For instance, I can get my Googlemail and my iGoogle homepage as well as most/all Google pages; dh can get most of his homepage (though I can't get same page on my login). Otherwise there seems to be no rhyme nor reason to it. I can get some sites but not others. Have run diagnostic tests on BT Voyager configuration page but the results are meaningless to me.

Can anyone suggest what I should do?

prism Sat 24-Oct-09 11:25:35

Try turning the security off on the wireless network (ie the password protection) and see what happens. If that fixes it you can secure your network a different way, but see if the security is the problem first.

onagar Sat 24-Oct-09 12:59:55

'modem' can mean different things. What I call my router is strictly speaking a router AND modem. If you mean a box that both computers connect to and which then goes to the internet then can you restart it?

A DNS problem could explain why you can get to some and not others, but generally restarting things sorts it out.

A DNS server is a computer on the internet (probably at your ISP) which redirects you to the site you want. They do go wrong and also the modem 'remembers' things wrongly sometimes. Hence the restart.

For anyone having constant DNS problems it's possible to connect to a different DNS server and this page here explains how.

BadgersPaws Sun 25-Oct-09 09:44:59

Is it always the same websites that don't work?

If you can you list a couple of them here?

Also following the link on onagar's post it might also be worth selecting "Obtain DNS automatically", that's usually the default for most ISPs.

MsHighwater Mon 26-Oct-09 22:55:23

Ah, wouldn't you know it. Onagar's link seems to be in the "Nope" group. Will try prism's suggestion first and see if that works. Thanks for the help.

MsHighwater Mon 26-Oct-09 23:13:41

No, turning off the security didn't work either. Any other suggestions gratefully received tho' we do have a an IT boffin friend to approach for help (if only dh would get the finger out and phone him...)

WebDude Tue 27-Oct-09 15:33:10

well, from the openDNS site (which you cannot get) they show their own name servers (DNS) as having IP addresses of 208.67.222.222 and 208.67.220.220

Depending on what you are using (Mac OSX, Windows <something> or Linux <many varieties>) will control how you alter the settings.

Assuming for a moment that it is Windows, then on DH's machine (in case it goes nowhere!) try opening Network connections, then right-click on the wireless connection and choose "properties" at the bottom of the list.

Should be possible to see a list of entries, where one shows Internet Protocol (TCP/IP) and if you highlight that one, and click on Properties button you will see a screen which shows "Obtain an IP address automatically" and further down should say "Obtain DNS address automatically"

If you change that to be "Use the following ..." and enter the numbers given above then you can see whether it makes any difference.

It's a bit awkward (and risky) to suggest making the changes (as I cannot foresee what you will get, I've not been using Vista, for example) but it might be worth a go before DH's friend talks you through the same thing (or an alternative).

If these DNS entries don't make any difference, then it could be some firewall or other software blocking certain entries.

On further possibility (but really a long-shot) is that a bit of malware has altered a file (called the "hosts" file) and blocked these other sites. I've seen this when a client's son picked up a virus over MSN chat, someone suggested it was a screen save of J-Lo and he downloaded it... it made many changes, such as blocking symantec and lots of other anti-virus sites, and closed any browser or other window which mentioned "virus" so it was a pain to shut down!)

The hosts file holds very little normally, but you can add lines to give IP addresses for different domain entries and these over-ride the lookup, so the PC always goes to the entry in the hosts file. An entry of 127.0.0.1 means "this PC" (the one running the browser) so the following would stop requests for other sites from working, if they were in the 'hosts' file:

127.0.0.1 www.google.com
127.0.0.1 ads.mumsnet.com
127.0.0.1 www.bbc.co.uk

Of course you wouldn't put those in, but you can see how easy it would be to block them, or make some lookup go to a fraudster's site - eg

10.123.1.2 www.hsbc.co.uk
10.123.1.2 www.barclays.co.uk

NB the above numbers chosen at random, but you can see how it could divert a visitor...

WebDude Thu 29-Oct-09 13:41:24

Any news?

MsHighwater Fri 30-Oct-09 21:49:51

IT boffin pal came round today. I wasn't here for most of it so only got the roundup at the end of his 2 fruitless hours trying to solve the problem. He tried changing the DNS server without success (don't want to give the impression I know what that means - this is just what he said). He has advised us to try switching off the router for several hours - we're going to be away overnight tomorrow so will try that then - in the hope that the IP address thing will resolve itself. Failing that, we'll call our ISP (Orange) and see what they can sort out. I'm a bit nervous about following our suggestion, WebDude, when I know so little, but thanks for your concern.

WebDude Sat 31-Oct-09 13:11:31

It is very odd if he changed the DNS entries and it still didn't work...

If it still isn't getting anywhere after you've tried several hours switched off, it might be worth asking him to check the "hosts" file.

It depends on what version of Windows you're using, perhaps, as to where it is stored, but on XP it is usually in

Windows\system32\drivers\etc
and is called "hosts" (no .something)

Should be easy to open with Notepad - the one on this PC says

# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
(blah b;ah b;ah)
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost

If there are other entries it may be that which is causing problems. I suppose there might be some anti-virus or "family" settings (what browser are you using - can you try another browser, such as from www.getfirefox.com or www.opera.com - if necessary, can you download a browser at work or at a friend's/ relative's home and save it on a memory stick, to install at home?

Could possibly talk you through other tests using the MS-DOS command line (to see what works and what doesn't - at present it is not clear if:

1) DNS look ups are being pre-empted by "hosts" file

2) browser is "protecting you" from "unsafe" sites

3) some network security/ anti-virus / firewall software is "protecting you" or

4) something of the malware variety is doing nasty things to stop you getting to other sites.

It could be almost any combination of them!

Hope it gets sorted for you - will check back on Tuesday to see how you have got on!

MsHighwater Sat 31-Oct-09 22:44:50

We have two computers working (or not) off our network. The desktop is about 3 years old and has XP. The laptop is new and runs Vista.

The desktop has Firefox as well as IE but the problem affects both. I also have a new mobile which can access the internet via wireless and it is also similarly affected. Also, the laptop works perfectly when we can connect to another network (as tonight when we are staying at my folks' house). As a result, I have come to the conclusion that it can't be anything in either computer that is causing the problem.

I have my fingers crossed that the big switch off will solve the problem. We might well look seriously at changing our broadband package - probably long overdue anyway.

Thanks for your suggestions.

foxinsocks Sat 31-Oct-09 22:59:17

what BT voyager hub do you have and what did the diagnostic checks say?

we have bt business broadband and it's v good and ours is a LOT better since we got a new hub/router

other option is the MTU

bottom post in the thread gives you links to look at the MTU

MsHighwater Sun 01-Nov-09 21:34:09

It's a Voyager 2100. Here, word for word, is what the diagnostic test results said.

"Test the connection to your local network
Test your Ethernet Connection: PASS
Test your Wireless Connection: PASS


Test the connection to your ADSL service provider
Test ADSL Synchronization: PASS
Test ATM OAM F5 segment ping: FAIL
Test ATM OAM F5 end-to-end ping: PASS
Test ATM OAM F4 segment ping: FAIL
Test ATM OAM F4 end-to-end ping: FAIL


Test the connection to your Internet service provider
Test PPP server connection: PASS
Test authentication with ISP: PASS
Test the assigned IP address: PASS
Ping default gateway: FAIL
Ping primary Domain Name Server: N/A"

I've been on to Orange technical support but I was advised that it was a problem with the cipher strength of IE8 and that I should revert to an earlier version. I'm not convinced, though.

WebDude Tue 10-Nov-09 15:32:58

Cipher strength problem isn't impossible - from home when I want to check level of usage on Three (mobile dongle in use and no landline) sometimes Firefox reports the website as having too poor a level of encryption and won't let me view the page, not a jot I can do to tell Firefox I don't care and just want to see the darn page - very frustrating, I can tell you!

However, if it works when away at another location, it rules out cipher strength.

As for MTU (mentioned by foxinsocks) - that can cause problems and I have seen a site that does a test and offers a free download to view/ alter your MTU settings, but normally would avoid suggesting it.

Certainly if you've been with Orange / Wanadoo/ Freeserve for a while, it could be worth a change, depends on whether there is any deal (as an Orange customer) and what other ISPs you have to choose from as to whether it will make much difference...

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now