Talk

Advanced search

Bridge Camera has become shit?

(4 Posts)
RattieofCatan Mon 10-Aug-15 18:34:58

We have a Nikon Coolpix L830 which was taking okay photos up until a couple of months ago, now all of the photos it takes are really shit and slightly blurry, even the inanimate object ones. DH has been known to play with settings but I've corrected them all and it hasn't been the same since.

I'm really pissed off as I cannot work out what is wrong with it. I've gone through tutorials and "fixed" each setting but nothing is working to fix it. The shutter speed seems to have decreased and most photos are blurry. We've only had it since last October/November and I'm loathe to buy a new one as we haven't really got the money for it right now but if I want any photos of my holiday next week I think I'll have to!

cdtaylornats Tue 11-Aug-15 10:03:59

My first instinct would be to remove the batteries and completely power it down for an hour, then check it again.

WMittens Tue 11-Aug-15 14:45:05

The shutter speed seems to have decreased and most photos are blurry.

What mode is it in? Full auto, shutter priority or manual?
Is the exposure compensation set to zero?
Is the ISO set to Auto?

Although your shutter speed comment suggests it is a camera setting, I'll ask anyway: is the lens clean?

WMittens Tue 11-Aug-15 14:48:02

Ah shit, it just has a load of stupid "scene modes". Ignore the shutter priority question.

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now