Talk

Advanced search

Has anyone experienced problems after updating to Android 5.1.1?

(15 Posts)
GloriousGoosebumps Wed 03-Jun-15 07:00:49

I foolishly clicked on the update last night without thinking. Now my tablet will not connect to the home wi-fi because it can't obtain an IP address. I've switched the router off and on a few times (a high sophisticated problem solving technique!) but without success. In any event three laptops and various other devices are able to connect to the wi-fi so the problem is unlikely to be the router. I've also googled the problem but again without finding a solution to the issue with the IP address. Does anyone have any suggestions? Fortunately, the tablet's still recognising the sim card so as least I have 4G connectivity but the problem's driving me around the bend!

NetworkGuy Wed 03-Jun-15 11:21:00

What tablet is it?

(un) fortunately, both my newest phones are running 5.0.x (LG Spirit is 5.0.1, Motorola Moto G is 5.0.2), so no experience yet with 5.1.1

Can I suggest downloading something like 'fing' or 'Wifi Analyzer'

If your Settings shows WiFi is on, but you try either of those apps, they will report if WiFi is not enabled.

Since you know the key for your router WiFi, you could try 'Forget Network' on the Settings / WiFi page, then scan for networks and select your home WiFi, then re-enter the key.

Although I prefer ethernet cable, I have 5 WiFi networks running (I test things out a lot) and rarely see a problem over getting an IP address.

Good luck smile

GloriousGoosebumps Wed 03-Jun-15 12:35:10

Thanks for taking an interest Network Guy! It's a Nexus 7 (2013) LTE, which I've been really happy with up to now. I've already tried re entering the wi-fi password but with no success. I've not come across Fing or Wi-Fi analyzer before so I'll give them a try now. Given the recent problems with both Apple and Android updates, I could kick myself for not waiting to see if there were any reported problems with this update. I really must have been half asleep last night but I won't make the same mistake a second time! I did eventually find some advice on the internet but nothing that helped and the final piece of advice always seems to be to do a factory restore - which I really want to avoid, and might not make a difference anyway.

GloriousGoosebumps Wed 03-Jun-15 12:53:42

I've now tried both Fing and Wi-fi Analyzer. Wi-fi Analyzer confirms our wi-fi is working (very pretty graphics!) but Fing can't do it's job if the tablet isn't connected to the wi-fi - a bit of a catch 22.

NetworkGuy Wed 03-Jun-15 22:13:23

Ah, so the tablet's WiFi is certainly still working (showing signal from your home WiFi and any from neighbours too)...

Found an article > IB Times < about WiFi on v5.1 but it include 'forget network' and similar... so not many differences.

What channel is your home router WiFi on ? Only ask because if I set my router on some channels (above 11 from memory), then it becomes invisible to my iMac and Roku (NowTV box) so there's a tiny chance that your tablet is restricted... just a thought ( now you can see why the "magic" of WiFi sometimes annoys me and cables are so much easier to fault-find)

NetworkGuy Wed 03-Jun-15 22:23:18

Can you (temporarily) disable security on your router to check the tablet will actually connect (and if not, then we're up a cul-de-sac, but if so, re-enable encryption, with a key of your choice - or the same one if changing all devices in your home is too much to consider).

GloriousGoosebumps Thu 04-Jun-15 11:26:13

Thanks for the article.Unfortunately, our router is so old that I've no idea how to disable the security or what channel it uses. I popped into McDonalds today to see if the tablet would connect to their wi-fi and it did so now I don’t know what to think and fear that a factory reset may be my only option.

NetworkGuy Thu 04-Jun-15 21:59:04

The WiFi Analyzer app can show the channel numbers being used...

Get the pretty graphical display, hit the 'View' button and choose "AP list" (AP = access point)

Each network will be shown as SSID name (plus other info - MAC address)
next line will show "CH <number>" (where the channel number is in green)

They're listed in a fairly random order but you will spot yours anyway...

Reason I mention this is that many routers are set to automatically choose which channel. You can manually force them to use a particular channel.

Based on my observations of some 20-30 routers near my home (4 blocks of flats nearby, plus a pub and other properties over the other side of a main road, outside my estate), the ones used are routinely channels 1, 6, or 11.

I've manually set mine to 2, 5, 7, 10 and 12, but remember when I tried to use 13 or 14, my iMacs and some other items never showed them on the list. Are you getting strong signals from any neighbour's router on the same channel as yours ?

What router (which ISP) do you use ?
May be possible to find instructions for you.

fairbalance Fri 05-Jun-15 13:26:58

What is the make and model of your router?

GloriousGoosebumps Sat 06-Jun-15 13:08:06

Hi, I'm back again. The router is very, very, old but was working perfectly. It's a Netgear RangeMax WirelessRouter WPN824 v2. We use it with Virgin broadband.

Wifi Analyzer tells me we're using channel 6.

Thanks for sparing the time to offer advice.

fairbalance Sat 06-Jun-15 20:39:39

It may be easier to buy a new router if it is old they are cheap enough.

NetworkGuy Sun 07-Jun-15 12:24:28

I picked up a Netgear cable router (no VM on my street) at a car boot sale, just to use as a wireless access point. Think I only paid a fiver. If it really is so old you have no instructions or anything, I'd be tempted to get a newer router.

codewaist Sun 07-Jun-15 13:36:58

I had no end of problems with 5.x on the WiFi only version of the Nexus 7, I eventually solved it by rolling back to an older version of the is but this is not a simple process.

GloriousGoosebumps Mon 08-Jun-15 16:10:25

Hi Codewaist, I found instructions for rolling back to the previous version of android on Digital Spy but I wouldn't feel confident enough to attempt it.

Network Guy and Fairbalance, we've decided to upgrade our Virgin Broadband to the fastest speed as they're offering a free modem provided you can set the modem up yourself.

Not being able to connect to our wifi has certainly made for a trying few days.

Thanks to everyone for all your help.

LassUnparalleled Tue 16-Jun-15 00:45:20

I have had no problems with it on a Motorola G phone which is my spare phone but it's pretty awful on my main phone Samsung Galaxy 4.

I am getting lots of random rebooting and freezing and yesterday in the middle of constant rebooting it wiped the external storage card. Thankfully everything is stored on various cloud accounts.

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now