Talk

Advanced search

iPhone 4, unlocked, new sim, no service

(9 Posts)
HHH3 Mon 29-Dec-14 13:47:28

I got my old iPhone 4 unlocked for DS1. Got him a tesco sim. But whatever I do it's saying 'no service'. Have tried 'reset all settings' and 'reset network settings' but nothing is working.

I really want to avoid restoring it to factory settings if at all possible (although I will if it will definitely work). Any ideas please?

Lifesalemon Mon 29-Dec-14 19:10:41

Probably wrong as im not very techie but is there a chance you need to somehow register or activate the sim to enable it.

BertieBotts Mon 29-Dec-14 19:11:35

Yep you will have to activate the sim card. There should be a phone number in the packaging. Or go on their website.

BertieBotts Mon 29-Dec-14 19:13:11

OK don't go on the website. Website is a pile of poo!

HHH3 Mon 29-Dec-14 19:44:29

They didn't say anything about activating the sim! It's contract not payg. Would it still need activating?

HHH3 Mon 29-Dec-14 20:35:26

I rang tesco. Sim doesn't need activating. They checked it anyway and there are no problems with it. They said as it's an iPhone to complete the unlocking process it needs to be connected to iTunes. Have just done that and...nothing sad Still no service.

It's too late to ring my provider now so I'll have to do it in the morning. Starting to wish I'd never started this!

widowerbutok Mon 29-Dec-14 22:56:07

Hi, I googled the problem and there are a number of sites that my help, this being one:-

https://att-iphone-unlock.com/iphone-no-service-factory-unlock-troubleshooting-guide/

Hope this helps

EmbroideredCloths Mon 29-Dec-14 23:07:37

My sister had this problem when I gave her my old iPhone 4 after factory resetting it. I'd been on O2 and she wanted to use PAYG giffgaff which piggybacks on the O2 network.

But it kept saying no service.

We took it to the O2 shop and they sorted it. It was all about connecting it to your iTunes account via a computer. For some reason, just connecting to iTunes via wifi wasn't enough.

Working absolutely fine now.

May I ask why you don't want to factory reset?

HHH3 Tue 30-Dec-14 08:59:47

Thanks for the link - I'll have a look.

Connected to iTunes via computer last night which did nothing. DS has been using the phone for a while to take photos/play games etc and I just didn't want to wipe it. I may have to though.

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now