Advanced search

New tablet not charging properly

(3 Posts)
ots Sun 20-Oct-13 22:19:29

I bought a tablet on Friday. It's from Argos, a Bush MyTablet for £100. It was only released a few days before so I can't find much help online. I really like it, ok it's no iPad but I wasn't expecting it to be for the price. The only problem I'm having though is with the battery. It won't charge any higher than 83%. I've tried charging with the mains plug and the USB, but it makes no difference. I've tried letting the battery run right down and then charging it from flat, but it still only got up to 83%. Can anyone shed any light?

mineofuselessinformation Sun 20-Oct-13 22:25:26

Are you still using it while charging? This will run the battery down even though its plugged in. If you've been just leaving it to charge, I would take it back.

ots Sun 20-Oct-13 22:28:34

No I've just been leaving it to charge. Yeah think that's what I'll have to do.

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now