Advanced search

BBC iPlayer app

(23 Posts)
FacebookWanker Thu 10-Oct-13 20:55:13


We've just downloaded the BBC iplayer app for our iPad, but it won't work because it thinks we're outside the UK. I've rebooted the router as suggest on the BBC help page, but it still doesn't work. It works on the Kindle anyway so it can't be the IP address. Does anyone have any suggestions?

widowerbutok Fri 11-Oct-13 11:50:32

Has the ipad changed yr location from the UK?

AngeleDei Sat 12-Oct-13 12:19:58


are both the ipad and kindle connecting to the internet over wifi and using your router, or is one using 3G? Are you using the ipad app from the itunes store to access iPlayer or are you using the browser ( Do you get the same fault with each?

Are you using a d-link router? Apparently there are some issues with these (no idea why), but it appears you are not aplone in being unable to get iplayer working on an ipad. Someone suggests doing the following : (Go to system preferences, energy saver, switch off automatic graphics switching ). Personally, I cant see that working, but who knows.

Other suggestions are make sure your ipad is fully updated and you uninstall and reinstall the app.

FacebookWanker Sun 13-Oct-13 21:45:02

Thanks for your suggestions. I will check our location and also try the graphics switching. I'm not sure if we have a d-link's a Sky router.

Both Kindle and iPad are connected to the wireless network. I've tries both the app and the BBC iPlayer website. Both have the same problem.

nannynick Sun 13-Oct-13 22:21:53

So it's not likely to be anything to do with the router. The problem is more likely with the iPad... where did you get it? Is it a UK model?

Does anyone use NetFlix on it and have they installed anything, or changed anything so that they can access NetFlix USA?

nannynick Sun 13-Oct-13 22:28:28

Check your Apple ID

Settings, iTunes & App Store, click on Apple ID: youremailaddress

Click View Apple ID, then enter your password if prompted.
Look where it says Country/Region. It needs to say United Kingdom.

Click DONE

Then delete the iPlayer app.

Then go to App Store and download the iPlayer APP by searching for iplayer. Make sure iPad Only search category is selected.

Go back to the ipad Settings page.
Select Wi-Fi and click the i symbol next to the network you use.
Scroll down that page to see if there is any Proxy being used. If there is, then that may be the issue.

Give that a try. Might not do anything different but maybe it will.

nannynick Sun 13-Oct-13 22:30:53

When in the Wi-Fi settings page, have a look at DNS... what number are there?

FacebookWanker Sun 13-Oct-13 22:31:13

It was purchased in the's an iPad 3.

We haven't installed Netflix or anything like that...I just saw on another forum that someone else had the same problem, but his suddenly started working so here's hoping...

FacebookWanker Sun 13-Oct-13 22:32:36

Just looking for DNS...

FacebookWanker Sun 13-Oct-13 22:39:40

Finally found the DNS settings...there's a number starting with 192

FacebookWanker Sun 13-Oct-13 22:43:58

In the settings the DNS and the router have the same number, but the IP address has 1 digit different - the last digit. Not sure if that is significant...

nannynick Sun 13-Oct-13 22:54:31

If it starts 192 then it is likely to be an internal network address, which is provided by the DHCP server. So that should be fine, as the Kindle is probably using the same thing.

Anyone have Sky Broadband and can confirm that the DNS setting is 1 digit different from the Router address?

FacebookWanker Sun 13-Oct-13 22:58:41

Thanks for your help with this nanny. I really appreciate it.

nannynick Sun 13-Oct-13 23:00:42

Seems rather odd. I wonder if taking it to Genius Bar at an Apple Store is worthwhile. Maybe they could figure it out.

Have you tried it anywhere else... that would help indicate that it was a problem on the iPad and not something to do with your specific internet connection.

FacebookWanker Sun 13-Oct-13 23:06:50

I'll try it t work tomorrow and the try the Genius Bar. All the settings say that I'm in the UK...very odd...

nannynick Sun 13-Oct-13 23:19:55


Settings, Privacy, Location Services
Make sure it is On (green colour).

Settings, General, Profile
Look for anything in there, for example I have:
WiFi Profile powered by The Cloud
Which enables me to connect to WiFi at The Cloud hotspot locations.

If you have anything in there, you could try removing them. Though it may well be empty.

nannynick Sun 13-Oct-13 23:27:54

Just wondering...

Settings, BBC iPlayer
Version should be

Is yours the same?

FacebookWanker Tue 15-Oct-13 11:43:27

In my profile I've got something called Themesoft. I just tried to delete it but had a warning that it would change the settings on the iPad so I left it.

I have the same version of iPlayer.

My location services are turned on, but the arrow is grey, not green.

FacebookWanker Tue 15-Oct-13 21:04:08

Our Sky Go has stopped working too. On the Sky website they've provided steps to change the adjust the wireless channel so I will give that a try when I can find out Ethernet cable.

Thanks again for all your suggestions.

Cindy34 Wed 16-Oct-13 00:02:18

On the ipad go to and see if it can determine which country you are in.

nannynick Thu 17-Oct-13 12:01:25

SkyGo I think also uses GeoIP to determine location, so the issue could well be due to the IP address your router is getting from your ISP.

Use to find out your IP address and see if it can determine country. If not, try turning your router off (or modem if on fibre) and waiting a while, say 20 mins. Then try again, router may obtain a new IP address.

FacebookWanker Sun 20-Oct-13 09:53:08

Fmbip locates us in the UK, but still no joy....I shall turn off the modem when we go out later...

nannynick Mon 21-Oct-13 23:35:39

Given it is a Sky Router and SkyGo is one of the apps not working, I would call Sky... presuming they are still your current broadband provider. I know that may be hard going but what else is there to try... fmbip says you are in the UK, so that's positive, yet the SkyGo app is refusing to work, and iPlayer moans about you not being in the UK.

One suggestion on the Sky Community Forum is to delete the SkyGo App. Fully reboot the iPad. Then redownload the SkyGo app.
Worth a try if you have not done so already I guess.

Perhaps try posting on the Sky Forum about SkyGo, Apple IOS7

Once you have SkyGo working, then you never know iPlayer may just start working... can but hope!

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now