Advanced search

Kindle Fire won't charge - turns out it was a software problem

(2 Posts)
difficultpickle Sat 21-Sep-13 13:07:27

Less than a year old. I tried three different chargers plus also tried charging via USB port on computer. Also tried holding off button for 20 seconds. None of it worked. Finally today I got around to calling Amazon. Apparently they had a software code issue some time ago and my Kindle was one of the ones affected.

A new Kindle is on its way although I'm a bit confused as to why they didn't email me to tell me there was a problem with my Kindle (I assumed it wasn't charging due to something I was or wasn't doing). Having said that I'm impressed at how quick they were to arrange to send out a new one.

crochetkate Sat 21-Sep-13 19:16:16

at least its in warranty and they are quickly replacing smile

Mine broke last week but out of warranty, i need my kindle, how else can I enjoy a bath wink

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now