Talk

Advanced search

Second baby - lost plug, period pains, 40+11 - please let this be it!

(7 Posts)
ecuse Wed 26-Nov-14 09:37:23

Was induced at 40+7 last time so no experience of going into labour naturally and not sure what to expect.

40+11 today, booked in for induction the day after tomorrow.

Lost my plug overnight, had low achey period pains for 2 hours but fairly constant, not coming and going like contractions. Also vaguely queasy and mild headache. But I could be symptom spotting.

Had a sweep two days ago at which I was 1.5 dilated but only 30% effaced. Both of which were progress compared with a week previous.

Someone come along and tell me I'm going into labour today?!?! grin

TiredNow Wed 26-Nov-14 09:44:15

You are going into labour today! grin

Fx if now that its all starting to kick off!

ecuse Wed 26-Nov-14 09:50:15

Thanks. Someone on MN has said it now, so It Shall Be So. grin

dollydaydream27 Wed 26-Nov-14 09:55:32

That's how mine started! Two days after a sweep... Born 3pm next day ... Good luck x

TiredNow Wed 26-Nov-14 16:21:21

How's things going OP?

ecuse Sat 06-Dec-14 06:14:44

It was a false alarm in the end. I was induced at 40 + 13 in the end, so didn't get the lovely serene waterbirth of my (naive?) imagination. But I did have a scrumptious baby girl last Saturday grin

LineRunner Sat 06-Dec-14 06:29:04

flowers That's brilliant.

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now