Talk

Advanced search

Medela Swing

(13 Posts)
MB34 Sun 11-Nov-12 20:58:53

I know this isn't about bf'ing/expressing as such but just wondering if anyone can help?

I bought a medela swing from ebay (advertised as used but working), but when I set it up and tried it, it didn't work.

I have bought a new tube, breast shield, valves and membranes and put it together as per the instructions from the medela website but still nothing.

It makes the right noises and the light is on but my boob doesn't get sucked into the breast shield.

Is there something I am missing or have I been conned??

MatriarchalDreams Sun 11-Nov-12 21:44:12

Have you got your nipple right in the centre? If it's even a little bit off it can make a difference. Also are you holding it straight? If it's at an angle that can affect it too. What size is the shield you're using? You can buy different sizes depending on the size of your nipple. You've probably checked all these things already. I think that also you should be able to see air moving in the tube when it's on but I might be wrong and I need to buy more tubing for mine so I can't check.

Impatientwino Mon 12-Nov-12 00:28:29

If you connect the tube to the pump and turn it on and put your finger over the end of the tube can you feel any suction?

Also make sure you have the tube in the 'tube' hole on the pump rather than the power one! I did that! blush

discombobwotsit Mon 12-Nov-12 02:22:48

Have you tried turning the suction up straight away? I find mine doesn't suck very strongly when first turned on.

Sparklesandglitter Mon 12-Nov-12 03:39:41

The first couple of minutes just stimulate milk flow there's a button to press to skip that stage

MB34 Mon 12-Nov-12 10:29:38

Thanks for your replies, unfortunately we've tried most of these.

There's absolutely no suction there whatsoever on either setting, I can't feel anything with my finger nor does my nipple move a millimetre.

I've bought a large size breast shield as the medium did look a little small but nothing with either

Think I have been conned :-( - will have to send a message to the seller.

KnitterInTheNW Mon 12-Nov-12 10:35:48

Really hoping that you didn't buy my pump, I sold mine on ebay not long ago. Mine worked before I sent it, I checked!

When you switch it on, have you tried pressing the '+' button until the auction's at it's strongest? Also, make sure that the tube is pushed right into both the pump and the other end - if it's even slightly pulled out I found that the suction was rubbish.

KnitterInTheNW Mon 12-Nov-12 10:38:25

Suction, not auction...

discombobwotsit Mon 12-Nov-12 13:43:06

just thought, have you checked the small white rubber valve? mine had a tiny hole in it that stopped it sucking effectively

discombobwotsit Mon 12-Nov-12 13:44:22

ignore me, just seen you already bought new bits... sorry

MB34 Mon 12-Nov-12 17:25:53

Hi Knitter - if it is you, I've just sent you a message on ebay lol!

I have tried putting it up to the strongest suction on both settings but nothing :-(
I think I've pushed the tube in fully - it didn't go in all the way on the breast shield end but it won't go in any further and I did use a fair bit of force.

KnitterInTheNW Mon 12-Nov-12 18:35:10

Not mine then! smile

BettyandDon Mon 12-Nov-12 18:40:27

I think it sounds like the motor is knackered. I had a 2nd hand one and the strength of the suction went after a few months.

I hope you get your money back as these things are not cheap even on ebay.

If you are heavy duty expressing it may be best to buy a new one or rent a double. It soon becomes the most used item in the house and it's important it's working well.

Tis crap though when all the expressing gadgets end up costing more than formula !

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now