No hot water

(7 Posts)
BradfordMum Mon 28-Dec-15 21:39:11

This morning, our hot water was lukewarm.
We've had this before when the immersion heater went, so we bought a new one and replaced it. A Plummer friend checked it and said it was all ok and we'd have hot water in an hour or two.
But we don't! 😓
What else could it be? He's coming back tomorrow but I'm in dire need of a hot bath! X

NorksAreMessy Tue 29-Dec-15 07:53:18

Have you checked the water pressure? If it is below the recommended pressure, it will never run hot enough

PigletJohn Tue 29-Dec-15 09:50:58

do you live in a flat with a hot-water cylinder and no boiler?

What colour is the cylinder?

BradfordMum Tue 29-Dec-15 12:53:52

Water pressure is fine.
No, a 5 bed semi.
Central heating is totally separate.
Tank was replaced about 5 years ago. It's blue.
This is about the 5th immersion heater in 10 years. It normally trips the circuit and we know straight away it's the immersion heater in the tank. This time though, the water was just cool. It didn't blow fuses or anything.
We have a man here now who's flummoxed by it!

PigletJohn Tue 29-Dec-15 16:02:49

if you have a CH boiler, doesn't it heat the hot water cylinder?

BradfordMum Tue 29-Dec-15 18:00:50

Sorted! We have hot water!
It appears the new IH we bought was broken. DH returned it and Plummer in another new one and it worked!!!

BradfordMum Tue 29-Dec-15 18:01:13

Sorry. Plummed x

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now