Webchat with Tristram Hunt, Labour education shadow, MONDAY 27 April at 12 midday ×

Just lost mucous plug....how much longer now?

(31 Posts)
bumpitybumpbump Sat 16-Mar-13 11:15:07

i'm 39 weeks today and just lost mucous plug this morning....decent quantity of mucous with tiny flecks of blood so pretty sure that was it. Have been having strong BHs for last few weeks at night time but no proper contractions or signs of waters breaking or leaking. Should I be preparing for imminent labour or could it still be a week or so? I have some errands to run and am now terrified that my waters wil break whilst perusing the granny pant section of m&s! Any advice or experience gratefully received! X

Iggly Sat 16-Mar-13 13:36:31

Keep on as normal. Wear a thick sanitary pad if you're worried although its rare to get that "gush". I found walking about really helped.

BigRedBox Sat 16-Mar-13 13:46:30

6 hours after I had a show I had a baby...

Show at 4.45am,
Waters at 5am,
Baby at 09.30 am

Weissdorn Sat 16-Mar-13 14:27:32

Message withdrawn at poster's request.

Glittertwins Sat 16-Mar-13 14:31:30

Over 4 days and had waters broken/induced at hospital. Not even a sweep after the plug came out got things moving although it was painful.

catlady1 Sat 16-Mar-13 14:33:51

You might go into labour at any point but the chances are it will start slowly and your waters might not break spontaneously at all. Get things done now while you can! Good luck!

squidkid Sat 16-Mar-13 15:43:15

My waters broke 3 days after I had a show (on my due date). Baby was 30 hours after that.

KittyMcAllister Sat 16-Mar-13 15:44:29

Two weeks here, though it came away slowly.

DangerMousey Sat 16-Mar-13 16:32:29

Show on Thursday night, contractions started Friday late afternoon, baby born 0900 Saturday morning (dc1). Waters didn't break until 0600am on the Saturday morning by which time I was nicely set up in the birth centre :-)

gingeme Sat 16-Mar-13 16:34:01

Plug went around 10am painful bhs for about 48 hours baby born 12 hours later. Water broke on delivery with 4 out of 5 of my DC. 1 st one the mw broke them for me. Good luck and try to relax xx

nemno Sat 16-Mar-13 16:36:32

I was induced 2 weeks after a full show. Sorry

BabyRoger Sat 16-Mar-13 16:41:45

I went into labour 6 days after my show with dd. Never had a show with ds.

ChocolateCoins Sat 16-Mar-13 16:43:11

I think it's different for everyone. I went into labour the day after losing mine. Good luck!

SilverSnake Sat 16-Mar-13 16:43:25

Child 1 show and then stright after my waters then 48 hours I went into labour 9 hours later baby by forcepts.

Child 2 show then 30 mins later contrations, from show till baby was 4 hours.

bumpitybumpbump Sat 16-Mar-13 18:30:00

Thanks everyone....the day has proven uneventful so far although I do feel like there's more pressure than normal on my cervix so hopefully not long now! Managed to waddle to the shops and out run the parking warden who showed no sympathy for my immobile state so consider it a successful day nonetheless!

So I think the consensus is that it could be anything from imminent to weeks so I'm packed and ready but have downloaded some more box sets just in case I'm back to waiting...will let you know if anything progresses...I just want to get on with it now! Xx

gingeme Sat 16-Mar-13 20:33:56

Wow sounds close. Keep on the move as much as you can. Gravity is a fab thing. Just one piece of advice which my mw gave me with Ds1 and I remembered it right through to Ds5. When your pushing that baby into this world don't scream. All it achieves is a sore throat. Good luck xx

girliefriend Sat 16-Mar-13 20:36:34

I had this on a monday and finally had my dd the following thursday!!

mumarchy Sat 16-Mar-13 20:38:07

waters broke 3 weeks after losing mucous plug, though the doctor said it could happen anytime....smile

gingeme Sun 17-Mar-13 17:06:06

Any News ? smile

Loislane78 Sun 17-Mar-13 19:32:50

Went about 10am, labour started early evening, born next morning.

GL!!!!! smile

gingeme Mon 18-Mar-13 19:45:07

Bumpitybumpbump ?

Haylebop12 Mon 18-Mar-13 19:49:49

Show at 2am

Labour started 4am

Baby born 3pm

Good luck!

Alibabaandthe40nappies Mon 18-Mar-13 19:58:11

3 weeks after I had a show I had an elective section...

bumpitybumpbump Mon 18-Mar-13 22:33:19

Hi everyone! Well still no sign of the wee one.....have permanent lower back ache and period type pains, but she is still kicking me in the ribs so I don't think fully engaged yet. I haven't tried raspberry leafvtea yet, should i? Tried all the other traditional recommendations and frankly in don't think my nipples could cope with any more tweaking blush

Join the discussion

Join the discussion

Registering is free, easy, and means you can join in the discussion, get discounts, win prizes and lots more.

Register now